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Introduction

This document provides users with essential tasks associated with Wordfast Pro (WFP)
and assumes you are already familiar with the interface and basic software functions. Use
the online help for more details.

Save a file
As you work on a file, frequently save your changes to a local folder.

To save a file:
1. Click the File tab, if you are not already on it, and then click the Save File as
Translated, Save or Save As button.
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Progress Table File Layout Translated
Save File As Select to save the translated file to a local folder.
Translated
Save Select to save the .TXLF file to a local folder with the existing file
name.
Save As Select to save the .TXLF file to a local folder under a different
name.

A progress bar is displayed. After successful completion, the file is updated in a local
folder.

2. (Optional) Continue with your translation or review. When you have finished, it is time
to complete the file.



Chain files

To combine multiple files and view them as a single file, use Chain Files. For example,
if you are translating or reviewing ten files with ten segments each, you can temporarily
chain them into a single file of 100 segments. Chaining files is particularly useful when
working with duplicate or similar content among files.

You cannot export or save chained files as a single TXLF file.

You can open and work on a single chained file or multiple sets of
chained files in the TXLF Editor view. Each chained file displays on

its own tab.

To chain files:



1. In the Current Project view, on the Project Files tab, select a set of files, then click
Chain Files.

Use Shift+Click to select sequential files or Ctrl+Click to select
individual files.
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The chained file opens in the TXLF Editor.

To determine the related file name for a segment, hover over the
segment ID.
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For example, there is an image of the web accessibility
symbol to the left of this paragraph.
Its alternate text is "Web Access Symbol”.
Alt text should communicate what an image means,
not how it looks.
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2. Click a segment to make it the active segment.

The file name changes from the chained name to the source file name of the active
segment.
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3. From the File tab, click Save.

If you need to review the files again, the chained files will open in the
same order you saved them.

The segments are saved in the chained file and restored to their original files without
the chained format. The progress for each individual file will show on the Progress tab.



Translate a file

Save your work often by clicking Save on the File tab or by pressing

~  Ctrl+S.

To translate a file:

1. On the Project Files tab, select a file, then click Translate File or double-click the file

name to open it.
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2. Select a target segment and enter the translation. If you have a translation memory
(TM) added to the project, you can leverage translations from it.
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This document provides
users with essential tasks
associated with
TransStudio Online (TSO)
and assumes you are
already familiar with the
interface and basic
software functions.
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3. Once you are satisfied with the translation, click Next Segment or Alt + Down Arrow.
This action updates the TM and moves to the next target segment. The segment state



changes to Translated. Segments that are changed to Translated are calculated on the
Progress Bar at the bottom of the window.

Segments: 24/33 | Segment (Src/Tgt/Max): 11/28/ | Paragraph {Src/Tgt/Max): 29/28/- _Ieﬂ}

As you translate, you can also commit the active segment to the TM
by selecting the Next Needs Translation Segment shortcut key (CTRL
+ Enter), and the active segment state will change to Translated

and then moves to the next segment whose status is set to Needs
Translation.

Copy all tags

Use Preferences > General Preferences > Tags to configure tags as
full-sized or shortened.

To copy all tags:
1. In the TXLF Editor view, open a file.
2. On the Edit tab, click Copy All Tags.

All copied tags display at the location of the cursor. Reorder them
to mimic the source content order using the drag-and-drop or copy-
and-paste technique.
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3. Select Segment or Document from the drop-down menu.

Segment or Alt+A  Select to copy only the tags for the selected segment to the
target.



Document or Alt-  Select to copy all tags for the entire document.
Shift+P

All tags are copied to the segment or document.

Find and replace content

Use Find/Replace to search for and replace text in translated content.
To find and replace content in a file:

1. In the TXLF Editor view, click the Edit tab.

2. Click Find/Replace.
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3. On the Find/Replace dialog, click in the Find what field, then enter your search text or
select it from the drop-down list.

Find/Replace x
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— Direction — Options
Backward ~ Ignore Case | Search Source
'+ Forward | Whole Words Only  ~ Search Target
| Ignore NBSP | Search Open Files
Use Regex




4. (Optional) Click the Expand icon ¥ to expand the panel for additional options, or click
the Collapse icon # to collapse the additional options.

Search text can include regular expressions (Regex), wild card
characters, and non-breaking spaces.

5. Click Find Next to move through all instances of the content.

6. (Optional) Click Reading Highlight and select the Highlight All action from the
drop-down list to highlight all instances of the content in all open files. Click Clear
Highlighting to remove the highlighting from the previous search.
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(Optional) You can filter table segments using the Segments with find/replace
highlight all table filter to see all segments containing text highlighted by Highlight All.

7. (Optional) To replace regular expressions, wild card characters, or words, click the
Replace icon “.. For additional options, click the down arrow on the sidebar.



8. Click in the Replace with field and enter the replacement text.
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9. (Optional) Select the direction of the search and any other options.

{ )
You cannot use the Whole Words Only search option when
entering multiple words or punctuation in either search field.
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Select Use Regex to search on regular expressions or wild card
characters.
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10. (Optional) Click one of the following actions: Replace, Replace All, Find Next, or Close.

The content you found has been replaced with the new content.



Transcheck overview

You can use Transcheck to scan translated content for linguistic and non-linguistic errors
such as missing tags, empty targets, numbers, and terminology within target segments.

© is displayed in the Status column for segments with errors.

To enable Transcheck and customize Transcheck options, configure
in Preferences > Current Project Preferences > Transcheck.

Use Transcheck

After you have configured Transcheck options, you can begin using Transcheck when you
translate or review a segment and commit it to the TM. You can also use the Transcheck
configuration option Transcheck segments while translating to check for errors during
the translation process.

To use Transcheck during translation:

1. In the TXLF Editor view, select a segment and complete your translation of that
segment.

2. Select Next Segment or press Alt+Down Arrow to update the TM, move down one
segment, and leverage the next segment from the TM.

3. (Optional) If Transcheck identifies an error in the segment, it posts a warning message.
Choose one of the following actions:

o Select Go back to fix issue to correct the error.
e Select Continue to continue translating without changes.

If you choose to correct the error, the Error Status icon @ is removed from the Status
column and from the Transcheck tab.

If you do not correct the error, the Error Status icon @ remains in the Status column
and on the Transcheck tab.



Use Transcheck All

Use Transcheck All to scan all segments of a file for non-linguistic errors in the target
segments and issue warnings for missing and incorrect text. Configure and enable
your Transcheck preferences under Preferences > Current Project Preferences >
Transcheck.

Do not use Transcheck All if you want Source and Target Consistency checks. Instead,
use Transcheck Report from the Project Files tab on the Current Project view.

. Use the Transcheck All option before you complete a file.

To use Transcheck All:
1. In the TXLF Editor view, finish translation of all segments in a file.

2. Click the Review tab, then click Transcheck All.
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In General Preferences under Warnings, if Transcheck All Warnings is selected

a Transcheck All Warning pop-up dialog appears. The "Do not warn me about this
anymore" checkbox will turn off this pop-up dialog. The Use Transcheck Report From
Current Project view link will open the Project Transcheck dialog.

3. Click Continue.

Transcheck All Warning x

Source and Target Consistency check will not be reported using Transcheck All
aption from TXLF Editor pane.

Use Transcheck Bepori From Current Project view o get report for Source and
Target Consistency Check.

Do not warn me about this anymore

A Transcheck report and summary results.



4. (Optional) On the Transcheck Report, determine the terminology errors you want

Transcheck to ignore from highlighted terms in the Terminology Check report section.

' ™)
To best optimize the Transcheck Report, you can configure

Transcheck to ignore highlighted terms you identify under
conditions you specify. The terms and conditions you select are in
the Ignored Terminology Errors section of the report.

Report is optimized for Google Chrome, some features might not work well in your current browser.
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Project TransCheck Report - Wordfastl - English - German
Report Summary (1 file)

TransCheck ran successfully on 1 file and found 39 errors.

Target Consistency Check ran successfully with 0 errors.

Source Consistency Check ran successfully with 0 errors.
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5. (Optional) Click a highlighted term.

6. (Optional) On the Ignore Terminology Transcheck Error dialog, compare the source
string with the target equivalents.

7. (Optional) Select either When term is for source terms in the glossary or When target
contains for target terms.

Ignore Terminology Transcheck Error

Source string: .
i *
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When Target
0O Contains:

Ignore Ignore All (3) M Next

8. (Optional) Either click Ignore to disregard the single instance of a string or Ignore All to
disregard every instance of a string.

The number following Ignore All contains the total number of
instances within that file.
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Source string:
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Ignore All (3) Previous Next




9. (Optional) Review the terms in the Ignored Terminology Errors section of the
Transcheck report.
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10. (Optional) After closing the Transcheck report, select any remaining segments with the
Error Status icon @ in the Status column.



11. (Optional) Click the Transcheck tab to examine the details of the segment error.

The total number of errors in the segment is the number in
parentheses on the Transcheck tab.

TM Lookup Notes Segment History Metadata Transcheck (3)

Previous error Next error Refresh lgnore warning

# Warning Explanation Cause

1 Tag Check Source contains Source contains "1, 2,
formatting missing in 3" which is missing in
the target. target.

2 | Unedited Fuzzy Target contains a Target contains a 98%

Check fuzzy match that has match that has not

not been modified. been modified.

3 Untranslated Text | Source text is not
Check translated in the
target.

"in" should be
translated in target.

12. (Optional) Click Next error or Previous error on the Transcheck tab to view the next
or prior segment error.

13. Choose one of the following actions:
e Correct the error and click Refresh to complete the correction.

e Click Ignore warning to continue reviewing error warnings without making any
changes.

If you correct the error, the Error Status icon @ is removed from the Status column.

If you do not correct the error, the Error Status icon @ remains in the Status column.
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